[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: F3 CDs

 --- Martin Kretzschmar <mk793652@mail.inf.tu-dresden.de> a écrit : 
> This can be hacked into apt without hacking, can't it? Yesterday I put
> something like this in a file /etc/apt/apt.conf.d/50apt-cdrom-hurd
>  Acquire::cdrom::"/cdrom/"::UMount "settrans -fag /cdrom";
> and apt-cdrom <unmounted> CDs correctly. I added the ::Mount entry, too,
> so that I could remove /cdrom from /etc/fstab.

I did the same thing, and it worked with apt-cdrom; mounts and umounts CDs
cleanly. But how it would work with dselect? I tried putting:

Acquire::cdrom::"/cdrom/"::Mount "settrans -a /cdrom /hurd/isofs /dev/hd3";
Acquire::cdrom::"/cdrom/"::UMount "settrans -fag /cdrom";

in the file /etc/apt/apt.conf.d/50apt-cdrom-hurd, but it isn't worked. I tried
so with export APT_CONFIG=/etc/apt/apt.conf and in apt.conf:

// Options for APT in general
//  Architecture "i386";

// Options for the downloading routines
    Mount "/cdrom";

    // You need the trailing slash!
       Mount "settrans -a /cdrom /hurd/isofs /dev/hd3";
       UMount "settrans -fag /cdrom";


   // Pre-configure all packages before they are installed using debconf.
   Pre-Install-Pkgs {"/usr/sbin/dpkg-preconfigure --apt || true";};

Finaly, I tried with export APT_CONFIG=/etc/apt/apt.conf.d/50apt-cdrom-hurd and
it isn't worked too.

By the way, in dselect I tried to set Access Method with CDROM, and it insisted
in use mount. Maybe I should try with apt? Thanks in advance.

|   |   |                    Cronos 
|   |   |            "No confies en nadie mayor de treinta" 
|   ----| 
|       |            Email: cronos1_mx@yahoo.com 
|       |            WWW:   http://www.geocities.com/cronos1_mx/

Do You Yahoo!? -- Pour faire vos courses sur le Net, 
Yahoo! Shopping : http://fr.shopping.yahoo.com

Reply to: