[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Just tried tarball+apt-get method

I decied to reinstall Hurd, because my installation was pretty dated.
Marcus recommended that I use the tarball and then apt-get.

It worked out ok once I got apt going. Except when I tried to
install the packages that I need for development. Turns out that
there is one single package in the archive that depends on
libc0.2 (>= 2.2.3-1) -- html2text. Unfortunately debhelper
depends on html2text. And since libc0.2_2.2.3 is not installable
(it's not in the archive or incoming), the problems just start
snowballing from there.

Like they say, a spoonful of dirt ruins a whole barrel of honey,
or whaterver your translation is.

Result is something like, it's impossible to install dpkg-dev,
autoconf, automake, etc.

Other problems is that the new version of perl packages has not
been uploaded yet. The perl*_all.deb packages are of a higher
version then the _hurd-i386.deb packages and thus cause some
problems (namely perl-modules).

Another thing is that pfinet had to be killed and restarted
periodically, but I think that's a known problem.


Reply to: