[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Known bugs about gnumach ide and scsi part and hurd-isofs-translator?

----- Original Message -----
From: "Marcus Brinkmann" <Marcus.Brinkmann@ruhr-uni-bochum.de>
To: "Henning Riedel" <hriedel@HTWM.De>
Cc: <debian-hurd@lists.debian.org>
Sent: Saturday, May 12, 2001 11:16 PM
Subject: Re: Known bugs about gnumach ide and scsi part and

> On Sat, May 12, 2001 at 09:29:40PM +0200, Henning Riedel wrote:
> > Hopefully, the included Makefiles are useful for you, as I just sending
> > from by outlook. I've found some ^L chars in them, and I wouldn't be
> > surprised if they don't actually belong there.
> The ^L is used as a page seperator in GNU source files, so the file is
> seperated into logical chunks.

I've had been some bash messages,where it said, it had found some unknown
characters on line 45, that's why I was wondering about the ^L. Don't know
which part of the compile it was.

> I am not sure why you posted the Makefiles.  They seem to come from the
> Hurd.  The kernel is GNU Mach, the Hurd is the Hurd.  So I suspect you
> trying to compile the Hurd (not the kernel).  I suspect you were doing
Yes, I actually tried to build the Hurd. Sorry that I missed to tell
I thought, it might help me, getiing a newer Hurd to maybe get rid of some

> As we never build directly in the source dir, there mightbe bugs
> it.  You seem to have encountered such a bug.  It's a low priority to fix
> but thanks for letting us now that there are problems.
Hmm, I should be more careful, what I'm doing. Next time I'll do it in

> > Some other problem that came up, was the locales-stuff, which gave me
> > at install per dpkg -i  of the locales-package the errors found in the
> > locales_err.log.
> Yes, there seems to be a problem.  I will try to look into it.
Thanks. I already asked a Prof. here at Uni. about all that locales-stuff.
Unfortunately, I won't have much time in the near future, since I also
developing Kernel-Mode-Drivers under Win2k/NT, which should be a base for
inturnships I want to do between semesters.

> > For the errors about the hd04 or the hd23, I can't provide a log-file,
> > the "cat /dev/klog >/tmp/boot.log" doesn't work. The size of the
> > is everytime 0 bytes. When I do a "cat /dev/klog" , the messages come up
> > on screen, but a redirection won't work.
> What exactly are you doing?  After "cat /dev/klog > /tmp/boot.log", does
> it return to the prompt, or sit there? If the latter, what do you press to
> interrupt it.

It won't return when I redirect to file. I just can do a CTRL-C. I tried to
CTRL-D, but it doesn't close the stream.
Should I rather try a >> ?

Thanks, Henning
Henning Riedel
Student of Computer Science (Technical), IF99w1
HTW Mittweida, University of Applied Science
e-mail:        hriedel@htwm.de
Homepage:  http://www.htwm.de/hriedel

Reply to: