[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Hurd crash when using "patch"


Now I've run into some really annoying problems. I've tried getting the
ssh 1.2.27 source, dsc and diff, to build it under the Hurd.
Unfortunately, the patch program causes the Hurd to crash and reboot when
the debian diff is applied to the source.

First I tried running it in gdb, with a result like this:

[gdb intro snipped]
(no debugging symbols found)...(no debugging symbols found)...
Program received signal SIGLOST, Resource lost.
Bus error
fps:/linux/usr/local/src/ssh-1.2.27# cd ..
cd: could not get current directory: getcwd: cannot access parent
directories: Computer bought the farm

After that, no commands worked and there was nothing to do except hitting
the power button.

Then I got the patch source and compiled it with debug symbols.
Unfortunately, when I ran my -g compiled patch in gdb, it worked
perfectly, patched all files successfully and didn't cause any problems.

Trying the -g compiled patch outside gdb, caused the following result (in
my telnet session):

fps:/linux/usr/local/src/ssh-1.2.27# patch -p1 <../ssh_1.2.27-2.diff
patching file `configure'
patching file `configure.in'
patching file `Makefile.in'
patching file `host_config.sample'
patching file `acconfig.h'
patching file `config.h.in'
patching file `ssh.1.in'
patching file `ssh-add.1'
patching file `sshd.c'
Unknown signal 32
fps:/linux/usr/local/src/ssh-1.2.27# Connection closed by foreign host.

After the "unknown signal" (which I gathered is SIGLOST, whatever it
means), the system rebooted immediatly.

I have no idea how proceed with debugging this problem, any advice would
be appreciated.

Regards, Pontus

Pontus Lidman, pontus@mathcore.com, Development & support manager
No matter how cynical you get, it's impossible to keep up.
Scene: www.dc-s.com | MUD: tyme.envy.com 6969 | irc: irc.quakenet.eu.org

Reply to: