[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: glibc 2.0.112 broken

On Wed, Feb 03, 1999 at 04:49:16PM -0600, Gordon Matzigkeit wrote:
> >>>>> Marcus Brinkmann writes:
>  MB> booting with glibc 2.0.112 installed:
>  MB> ext2fs.static etc etc init../../libdiskfs/boot-start.c:198
>  MB> diskfs_start_bootstrap unexpexted error: No such file or
>  MB> directory.
> Are you sure this was due to glibc?  Looking in boot-start.c, I see
> that this message is caused only when you try using Roland's
> experimental (and untested) --boot-command feature.

I did not yet tried this feature at all, sorry.
All I did was to install libc0.2_2.0.112 from Linux and rebooted.

If you want, I can do further testing by replacing individual libraries to
localize it. It  is most certainly a linkink problem (because the
ext2fs.static server comes up right, and the exec server, too).
> Don't use `--boot-command', and see if that works.  If you're not
> using boot-command, then something else is going wrong, but I'm not
> yet convinced that it's glibc's fault.

Reinstalling an older version fixed it.


"Rhubarb is no Egyptian god."        Debian GNU/Linux        finger brinkmd@ 
Marcus Brinkmann                   http://www.debian.org    master.debian.org
Marcus.Brinkmann@ruhr-uni-bochum.de                        for public  PGP Key
http://homepage.ruhr-uni-bochum.de/Marcus.Brinkmann/       PGP Key ID 36E7CD09

Reply to: