[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Aw: Upgrade woes - was Re: install/update/upgrade dance

On 5/23/13 3:36 PM, Helge Deller wrote:
On 05/23/2013 09:09 PM, Dave Land wrote:
Thanks for the reply Helge. I did manage to get it to find the proper kernel and boot from it, but I can't get it past the point where it hands over the boot console to tty0. It *seems* to be up, but I can't log in with PUTTY on a remote machine either by SSH or telnet. I also tried changing the IPL list to forward it to ttyS0, but nothing shows up on Tera-term, plus according to the LED display on the front of the HP, it seems to have crashed. My IPL list looks something like this:

0: 2/vmlinux-3.9
1: root=/dev/sda4 (actually correct according to how I partitioned)
2: initrd=2/initrd.img (removed according to instructions)
3: HOME=/
4: panic=-1 (tried with and without)
5: console=tty0
6: sti=10/4/2/0
7: sti_font=VGA8x6
8: TERM=linux

Maybe this may give a little insight to what is going on?

Yes, I have an idea.

I assume your machine is up an running. Just try to ping the machine.

Are you installing via serial console?
In that case change the value of "console" in IPL to
	console=ttyS0    (which is serial port #1)
and change the "TERM=linux" to "TERM=linux 1"  (a space between linux and 1)
This adds a 9th parameter "1" which instructs the kernel to boot into runlevel 1.
If it boots up, you should get a request to enter the root password.

Then remount the root-filesystem read-writeable, e.g. run "mount -o remount,rw /".

Then uncomment in /etc/inittab this line:
	T0:23:respawn:/sbin/getty -L ttyS0 9600 vt100
This instructs init ro spawn a login shell on ttyS0 (=serial console).

After that reboot again normally.


LOL, the mystery gets deeper. I tried the ttyS0 serial console edit again (it crashed the machine before), and added the extra line with '1' in it for run level 1, and once again it crashed, even after removing the references for the sti console. Incidentally, I'm normally booting to a graphics console, not serial... So I booted back up with my old kernel and went in and edited /etc/inittab and uncommented T0:23:respawn:/sbin/getty -L ttys0 9600 vt100 and went back and tried it again, and once again it crashed when it tried to switch to the serial terminal. So I rebooted with my old kernel once again, and lo & behold, when I got to the login prompt, I also had a login prompt on my serial terminal too... and both of them work. Still doesn't do me much good with the new kernel, but I thought it was kind of interesting that I have tty0 and ttyS0 simultaneously on the old kernel (2.6.26-2).

I've got one more thing to try, and that is remove the graphics card and boot it, and see if the firmware will default to the serial terminal. Maybe then I can get it to play nice until I do the apt-get upgrade. Theoretically, I should be able to get it to see the graphics card once the upgrade is finished and I reboot. I'll let you know what happens. Thanks for all your help.

Dave Land
Land Computer Service

Reply to: