[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Aw: Upgrade woes - was Re: install/update/upgrade dance

On 23-May-13, at 5:36 PM, Helge Deller wrote:

On 05/23/2013 09:09 PM, Dave Land wrote:
Thanks for the reply Helge. I did manage to get it to find the proper kernel and boot from it, but I can't get it past the point where it hands over the boot console to tty0. It *seems* to be up, but I can't log in with PUTTY on a remote machine either by SSH or telnet. I also tried changing the IPL list to forward it to ttyS0, but nothing shows up on Tera-term, plus according to the LED display on the front of the HP, it seems to have crashed. My IPL list looks something like this:

0: 2/vmlinux-3.9
1: root=/dev/sda4 (actually correct according to how I partitioned)
2: initrd=2/initrd.img (removed according to instructions)
3: HOME=/
4: panic=-1 (tried with and without)
5: console=tty0
6: sti=10/4/2/0
7: sti_font=VGA8x6
8: TERM=linux

Maybe this may give a little insight to what is going on?

Yes, I have an idea.

I assume your machine is up an running. Just try to ping the machine.

Are you installing via serial console?
In that case change the value of "console" in IPL to
	console=ttyS0    (which is serial port #1)
and change the "TERM=linux" to "TERM=linux 1" (a space between linux and 1) This adds a 9th parameter "1" which instructs the kernel to boot into runlevel 1.
If it boots up, you should get a request to enter the root password.

Then remount the root-filesystem read-writeable, e.g. run "mount -o remount,rw /".

Then uncomment in /etc/inittab this line:
	T0:23:respawn:/sbin/getty -L ttyS0 9600 vt100
This instructs init ro spawn a login shell on ttyS0 (=serial console).

After that reboot again normally.

Another related idea is "init=/bin/sh". This has saved my booty a few times.

John David Anglin	dave.anglin@bell.net

Reply to: