[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Aw: Upgrade woes - was Re: install/update/upgrade dance

On 5/23/13 2:05 AM, Helge Deller wrote:
Hi Dave,

Von: "Dave Land" <xmechanic@landcomp.net>
Well, back to square one. If you can't get it to boot, you can't do
anything including accessing the disc to add/remove kernels, etc. This
is the last time I will go through this, and unless someone is willing
to take the time to create a netboot.iso that we can boot into an
updated kernel and point it to http://www.parisc-linux.org/debian
unstable main for the install, there's not much point in trying to

That's definitively on my todo list. But it will take me some time, because
a) I want to have a stable kernel deb package first (3.8 and 3.10)
b) I need to learn how to build the iso (just replacing packages on the
existing iso would be an option, but even this needs testing!).

So, maybe in 1-3 weeks I will have something.
For a) I still need to push some patches upstream and try to get existing
patches into 3.8-stable.

I just re-loaded from the Lenny CD's once again and used wget
to retrieve the new kernel and config, ran the tar xf command from / and
once again the new kernel shows up in /boot. Made sure there was plenty
of extra room there and re-booted. Got to 'interact with the IPL' and it
just hangs with a message about no magic LIF or some such thing.

You must be doing something wrong...
Are you sure you boot from the correct disc?
Enter command "search" at the boot prompt to see all discs.
Remember, that Linux SCSI discs numbers are differently that the one in IPL.

Main Menu: Enter command > search
Searching for potential boot device(s)...
This may take several minutes.
To discontinue search, press any key (termination may not be immediate).
    Path Number        Device Path              Device Type
    -----------        -----------------        -----------
    P0                 LAN.   100/Full Dx
    P1                 IDE                      FX4830T
    P2                 FWSCSI.6.0               QUANTUM ATLAS10K-18LVD
    P3                 FWSCSI.5.0               QUANTUM ATLAS10K-18LVD
    P4                 FWSCSI.4.0               SEAGATE ST118273WC
    P5                 FWSCSI.3.0               SEAGATE ST118273WC

You can then boot via "boot P2" for example to boot from that device.
If you know the device, you can the set this as default boot path,

Main Menu: Enter command > path primary FWSCSI.3.0
   Primary boot path:    FWSCSI.3.

In general, here is my bootlog (see comments in "()"):
Main Menu: Enter command > bo pri
Interact with IPL (Y, N, Q)?> y

Boot IO Dependent Code (IODC) revision 0

HARD Booted.
palo ipl 1.17 root@paer Sat Oct  2 09:57:32 UTC 2010

Partition Start(MB) End(MB) Id Type
1               1      31   f0 Palo
2              32     313   83 ext2
3             314   17359   83 ext2

(look at the partitions above, 1-3)

PALO(F0) partition contains:
     0/vmlinux64 7460908 bytes @ 0x48000

Information: No console specified on kernel command line. This is normal.
PALO will choose the console currently used by firmware (serial).Current command line:
2/vmlinux64 root=/dev/sda3 initrd=2/initrd.img HOME=/ panic=-1 console=ttyS0 TERM=vt102
  0: 2/vmlinux64
  1: root=/dev/sda3
  2: initrd=2/initrd.img
  3: HOME=/
  4: panic=-1
  5: console=ttyS0
  6: TERM=vt102

<#>    edit the numbered field
'b'    boot with this command line
'r'    restore command line
'l'    list dir
? b

Command line for kernel: 'root=/dev/sda3 HOME=/ panic=-1 console=ttyS0 TERM=vt102 palo_kernel=2/vmlinux-3.9-dave-dbit'

I'm going to throw this thing back into storage until a more stable install
solution is available. I've wasted enough time on it for one week. :(

I'm working on such a solution.


Thanks for the reply Helge. I did manage to get it to find the proper kernel and boot from it, but I can't get it past the point where it hands over the boot console to tty0. It *seems* to be up, but I can't log in with PUTTY on a remote machine either by SSH or telnet. I also tried changing the IPL list to forward it to ttyS0, but nothing shows up on Tera-term, plus according to the LED display on the front of the HP, it seems to have crashed. My IPL list looks something like this:

0: 2/vmlinux-3.9
1: root=/dev/sda4 (actually correct according to how I partitioned)
2: initrd=2/initrd.img (removed according to instructions)
3: HOME=/
4: panic=-1 (tried with and without)
5: console=tty0
6: sti=10/4/2/0
7: sti_font=VGA8x6
8: TERM=linux

Maybe this may give a little insight to what is going on?

Dave Land
Land Computer Service

Check out my site at http://www.landcomp.net

Reply to: