[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: libc6 2.3.5-3 crashes 3.0.14a-6

Hello Alexander,

Thanks for this report.

After some holidays, I first updated my unstable debian on my c110 (just a bit older then your c240 ;-) ).

Then grab the latest kernel cvs and tried to rebuild it but encountered following pb: o with (cvs dated 20050626) build with gcc-4.0: the system panicing while 'make menuconfig' ??

o with 2.6.12-pa0 (also build with gcc-4.0): system panicing again at the same place and same kind of
      kernel BUG at mm/mmap.c:????
[<1015c5e8>] exit_mmap+0x1b8/0x1d8
[<10126614>] mmput+0x44/0xbc
[<1012a928>] do_exit+0xd4/0xa04
[<1012b2bc>] do_group_exit+0x64/0xcc
[<1010d12c>] syscall_exit+0x0/0x14

Kernel panic - not syncing: BUG!

(unfortunately no cpu reg dump :-( )

o with system didn't panicing anymore but 'make' did a 'Segmentation fault'

but no other 2.6.10 in stock to check if it helps more like for you and samba ;-(

I would like to put Carlos in cc just to ask him if he was aware of this pb?


Any clue?


Alexander Bartolich wrote:

Alexander Bartolich wrote:
$ uname -srm
Linux 2.6.12-pa2c parisc

The kernel is custom build.

Problem vanished after installing Debian's 2.6.10-1-32.

The last Debian kernel I tried (2.6.8) did not boot at all
on my C240. Grant Grundler then was so kind to direct me to
a working configuration on his site.

Once again I can't give a reasonably description of the problem.
The diff between config-2.6.10-1-32 and my custom config-2.6.12-pa2
is about 1300 lines. And the amateurish tweaks I applied to the
kernel config from one upgrade to the other sure don't help.

Anyway, testing/unstable is once again running fine.

Reply to: