[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Elusive problem related to %gconf-tree.xml after testing upgrade

It may be related to a previous post about gconf not working.

I answered yes to migration during upgrade. All seemed to work fine.
Except windows would hang at various random points, sometimes crashing
the system to the point of not being able to switch to a tty.

I tried cleaning out .gconf, .gconfd, .gnome, .gnome2 in various
combinations. They all led to hangs with no consistent pattern, or
meaningful .xsession-errors. While I was thrashing around, I did another
upgrade which included certain gnome components. This did not help.

I also removed %gconf-tree.xml once, and answered yes to migration
again. It did not solve the hanging problem.

In addition, the following may offer a hint. While all audio was
working, including gnome-volume-control before upgrade and gconf
migration, the gnome-volume-control would not work with gconf migration,
even though all other audio/video worked.

Finally, I removed %gconf-tree.xml and rejected migration. I have not
had any hangs for a period of time longer than with migration. And
gnome-volume-control is working again.

The migration question did say that "certain scripts may break" when all
gconf data are combined into %gconf-tree.xml.

Even though not migrating seems to solve the hang problem for now, it is
still disturbing that I was not able to start afresh by removing .gconf*
and .gnome*.

I would be happy to do some more experiments if it would help find the


Reply to: