[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#526823: libc6: Not fixed in 2.9-10

cb474 cb474 a écrit :
>> Which DNS server are you currently using? Have you tried to use
>> "single-request" into /etc/resolv.conf?
> Thanks for the help. This is on my laptop, so the DNS server depnds on
> where I am. At home on DSL, my IP assigns the DNS server by name, rather
> than numerical address. E.g.:
> domain myip.net <http://myip.net>
> search myip.net <http://myip.net>
> This is where I have the problem. If the DNS server is assigned as a
> numerical address, it works fine. I've noticed this when am at other
> locations. Hence the opendns workaround solves the problem at home
> because the DNS server is assigned as a numerical address. E.g.
> nameserver

You are probably mistaken. DNS server *must* be given by IP. There is no
other solution. "domain" and "search" are directives to control the way
unqualified DNS queries are answered.

> I have not tried "single-request" in /etc/resolv.conf. I didn't really
> understand how to do that. Just add a line that says "single-request" at
> the end? start? of /etc/resolv.conf?

On a single line in the file, the location doesn't matter.
Aurelien Jarno	                        GPG: 1024D/F1BCDB73
aurelien@aurel32.net                 http://www.aurel32.net

Reply to: