[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#526823: libc6: Not fixed in 2.9-10

You are probably mistaken. DNS server *must* be given by IP. There is no
other solution. "domain" and "search" are directives to control the way
unqualified DNS queries are answered.

Thanks for the further help. I tried the "single-request" line in resolv.conf and it didn't help.

You're right about the DNS server, I guess. In addition to the "domain" and "search" lines in my resolv.conf, there is another "nameserver" line that specifies the IP address of my router, which I figured just had to do with something else. But I guess it's there to tell my system to get the DNS server from the router? In turn, my router specifies as the DNS server the IP address of my DSL modem/gateway/whatever-it-is. And then the DSL modem specifies the DNS servers of my IP by the correct numerical IP addresses.

I also tried just plugging my computer directly into the DSL modem, via ethernet, and bypassing my router, but still had the same problems and "single-request" didn't help there either.

But again directly specifying the DNS server addresses as "nameserver" entries in resolv.conf, either using the opendns addresses or those from my IP, does solve the problem. It just apparently won't work automagically through my router or through the DSL modem/router.

If it's useful information, I have another computer running Arch Linux, going through the same router and DSL modem and it is not having this problem. In the resolv.conf on my Arch system, there are just two lines, one that begins "search" and gives the name of my IP and the other that begins "nameserver" and then gives the IP of my router.

Reply to: