[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#368022: libc6: rational rose license manager fails to start since last glibc update

Daniel Jacobowitz wrote:
> On Sat, May 20, 2006 at 05:12:16AM +0000, Aurelien Jarno wrote:
>>> ./rational: relocation error: ./rational: symbol errno, version
>>> GLIBC_2.0 not defined in file libc.so.6 with link time reference
>>> Is there any workaround for this problem?
>> Well first we have to understand the problem. I don't really see what is 
>> wrong, as the symbol is present:
>> [henry:~]$ objdump -T /lib/libc.so.6 | grep errno
>> 000dfba0 g    DF .text  00000090  GLIBC_2.0   clnt_perrno
>> 0011f360 g    DO .bss   00000004 (GLIBC_2.0)  _errno
>> 0011f360 g    DO .bss   00000004 (GLIBC_2.0)  errno
>> 000d3be0 g    DF .text  00000028  GLIBC_2.0   __h_errno_location
>> 00120eb0 g    DO .bss   00000004 (GLIBC_2.0)  h_errno
>> 000155d0 g    DF .text  00000028  GLIBC_2.0   __errno_location
>> 00120eb0  w   DO .bss   00000004 (GLIBC_2.0)  _h_errno
>> 000df7e0 g    DF .text  00000083  GLIBC_2.0   clnt_sperrno
>> Which was the latest version which worked? Have you tried to upgrade the 
>> product?
> Older versions of Debian glibc would automatically "downshift" to
> non-TLS libraries; maybe his previously installed version did.
> Try LD_ASSUME_KERNEL=2.4.1 ./rational?

Well since glibc 2.3.6-7, all our "flavours" of the glibc now have TLS
enabled, since it is needed by libstdc++. So I doubt it will work.

  .''`.  Aurelien Jarno	            | GPG: 1024D/F1BCDB73
 : :' :  Debian GNU/Linux developer | Electrical Engineer
 `. `'   aurel32@debian.org         | aurelien@aurel32.net
   `-    people.debian.org/~aurel32 | www.aurel32.net

Reply to: