[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#368022: libc6: rational rose license manager fails to start since last glibc update

Martin Hans wrote:
Package: libc6
Version: 2.3.6-7
Severity: normal


since last glibc update the rational rose license manager produces the following
error message at startup:

./rational: relocation error: ./rational: symbol errno, version
GLIBC_2.0 not defined in file libc.so.6 with link time reference

Is there any workaround for this problem?

Well first we have to understand the problem. I don't really see what is wrong, as the symbol is present:

[henry:~]$ objdump -T /lib/libc.so.6 | grep errno
000dfba0 g    DF .text  00000090  GLIBC_2.0   clnt_perrno
0011f360 g    DO .bss   00000004 (GLIBC_2.0)  _errno
0011f360 g    DO .bss   00000004 (GLIBC_2.0)  errno
000d3be0 g    DF .text  00000028  GLIBC_2.0   __h_errno_location
00120eb0 g    DO .bss   00000004 (GLIBC_2.0)  h_errno
000155d0 g    DF .text  00000028  GLIBC_2.0   __errno_location
00120eb0  w   DO .bss   00000004 (GLIBC_2.0)  _h_errno
000df7e0 g    DF .text  00000083  GLIBC_2.0   clnt_sperrno

Which was the latest version which worked? Have you tried to upgrade the product?


  .''`.  Aurelien Jarno	            | GPG: 1024D/F1BCDB73
 : :' :  Debian GNU/Linux developer | Electrical Engineer
 `. `'   aurel32@debian.org         | aurelien@aurel32.net
   `-    people.debian.org/~aurel32 | www.aurel32.net

Reply to: