[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

SpatiaLite transition

After noticing that spatialite-tools was in danger of being removed from
testing, and seeing that the transition to 4.x had stalled, I've looked
into how to move this along again.

In the mean time most of the Gaia-SINS software had new upstream
releases. Some of which are interdependent. Version 1.7.1 of
spatialite-gui requires libgaiagraphics to be updated to version 0.5.

Not all of the Gaia-SINS software is maintained by Debian GIS, FreeXL is
maintained by David Paleino in collab-maint, and ReadOSM by David in
pkg-osm. Fortunately these new upstream versions are not required by the
packages that are part of Debian GIS.

For the SpatiaLite family the following packages where updated:

 1) libgaiagraphics  (0.4b  -> 0.5)
 2) spatialite       (4.0.0 -> 4.1.1)
 3) librasterlite    (1.1d  -> 1.1g)
 4) spatialite-tools (4.0.0 -> 4.1.1)
 5) spatialite-gui   (1.6.0 -> 1.7.1)

Updating libgaiagraphics in unstable shouldn't be a problem. The symbols
that were removed in 0.5 were never used externally. libgaiagraphics 0.5
introduces SVG support, and no longer exposes the private gg_* symbols.

Although libgaiagraphics 0.5 is required to build spatialite-gui, none
of its symbols are used. The SVG support with libxml2 in spatialite-gui
is incomplete and has been disabled to allow it to build.

Updating spatialite in experimental is required to fix the FTBFS on
armel, armhf, mips & mipsel. The testcase causing the build failures has
been disabled on advise of upstream (#725267).

Updating librasterlite in experimental first requires spatialite to be
updated. The build for librasterlite 1.1d failed on powerpc due to the
use of an outdated libspatialite build dependency (#725271). The
spatialite version in unstable will satisfy the requirements, but wasn't
used yet at the time of build.

Updating spatialite-tools in experimental also requires spatialite to be
updated first. The 4.0.0-1 version FTBFS on hurd-i386, caused by the
same issue that threatened its removal from testing (#713644). While the
error is not identical, the improper linking of sqlite3 is also the cause.

Updating spatialite-gui in experimental requires the update of
libgaiagraphics, spatialite and librasterlite first. It has the same
FTBFS on hurd-i386 as spatialite-tools, also fixed by properly linking

The SpatiaLite update in encompasses two transitions:

 1) libspatialite3 (3.1.0~rc2-2) -> libspatialite5 (4.1.1-1)
 2) librasterlite1 (1.1~svn11-2) -> librasterlite2 (1.1g-1)

The reverse dependencies of both libraries are quite limited
fortunately. I've verified that all reverse dependencies still build
successfully using the new spatialite and rasterlite packages.

QGIS being the exception. It FTBFS because libopenscenegraph99 has
become uninstallable. This problem also plagues the update for osgEarth,
which is not related to the spatialite transition though. Packaging for
the new 2.0.1 QGIS upstream version is available in git, and an old
build is still available on mentors (RFS #724927).

With fixed OpenSceneGraph packages installed locally, the rebuild of
QGIS succeeds with the new spatilite library.

An overview of the rebuilds for the transitions is included below, and
example ben files for the transitions are attached.

Andreas has kindly offered his SoB for the uploads, so I'll use that to
coordinate the uploads of the packages in question.

I'll also request transition slots for spatialite and librasterlite from
the Release Team once the packages are in experimental.


Transition: spatialite

libspatialite3 (3.1.0~rc2-2) -> libspatialite5 (4.1.1-1)

Affected source packages in unstable:
 gdal             (build OK, update for experimental on mentors)
 merkaartor       (build OK, not co-maintained in pkg-{grass,osm})
 librasterlite    (build OK, update for experimental on mentors)
 spatialite-gui   (build OK, update for experimental on mentors)
 spatialite-tools (build OK, update for experimental on mentors)
 pyspatialite     (build OK, update for experimental on mentors)
 qgis             (build FAIL due to openscenegraph, OK with OSG fixed)


Transition: librasterlite

librasterlite1 (1.1~svn11-2) -> librasterlite2 (1.1g-1)

Affected source packages in unstable:
 mapnik         (build OK)
 spatialite-gui (build OK)


Kind Regards,


GnuPG: 0xE88D4AF1 (new) / 0x77A975AD (old)

title = "librasterlite2";
is_affected = .build-depends ~ "librasterlite-dev";
is_good = .depends ~ "librasterlite2";
is_bad = .depends ~ "librasterlite1";
notes = "libspatialite5 is required for librasterlite2 to build.";
title = "libspatialite5";
is_affected = .build-depends ~ "libspatialite-dev";
is_good = .depends ~ "libspatialite5";
is_bad = .depends ~ "libspatialite3";
notes = "libspatialite5 is required for librasterlite2 to build.";

Reply to: