[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Question about installing Debian 8.0.3 arm64 on EUFI



On Wed, Mar 16, 2016 at 3:52 AM, Leif Lindholm <leif.lindholm@linaro.org> wrote:
> On Tue, Mar 15, 2016 at 08:06:17PM -0700, Ronald Maas wrote:
>> > Did you also follow the advise stated at the bottom of that post?:
>> > ---
>> > Note: A few people have pointed out that the Gigabyte isn’t SBSA
>> > compliant because it lacks the right serial port, RTC and WDT. However
>> > it still boots RHELSA fine if you add console=ttyS0,115200.
>> > ---
Based on the information listed by dmesg, the serial ports for ttyS0
is one of 4 16550 UARTs integrated on the X-Gene SOC. Furthermore EFI
RTC driver is used. Was not able to find anything about WDT. But so
far the MP30-AR0 hardware seems pretty standard to me and in this
regard probably similar to other X-Gene based boards.

Actually I believe the only difference with this Gigabyte board is it
includes an AST2400 BMC chip. Which is kind of nice to have VGA
available

>> >
>>
>> > If not, break into grub and edit the command line by typing 'c', and
>> > add the suggested modification before the --- on the "linux" line.
>>
>> I tried several options, but unfortunately non of these had any effect:
>> console=ttyS0,115200 BOOT_DEBUG=2 DEBIAN_FRONT_END=text acpi=off
>>
>>
>> > There are a couple of reasons why the console might not be picked up
>> > automatically - I am not sufficiently familiar with the Gigabyte
>> > platform to tell which it is.
>> >
>>
>> I ran the Centos installer, and noticed their EFI stub displayed 2 more
>> lines compared to Debian's version:
>>
>> EFI stub: Booting Linux Kernel...
>> EFI stub: Using DTB from configuration table      <-----
>> EFI stub: Existing boot services and installing virtual address map...
>
> Yeah, these two lines only went into 3.16 kernel, and I don't think
> they were cherry-picked into the Jessie kernel.
>
>> <------
>> L3c Cache: 8MB
>>
>> Not sure if this is helpful or not
>>
>> Anyway. Thanks for the suggestions. Ronald
>
> I'm guessing there is something required to boot on the Gigabyte which
> is not yet supported on the Jessie 3.16 kernel.
>
> It would be interesting, but not vital, if you could try again, adding
> "earlycon" to the kernel command line. Won't help anything, but would
> potentially let me know what's going on.
Both earlycon and earlyprintk in combination with console=ttyS0,115200
did not display any additional information.

>
> What might help would be trying a newer installer, like the current
> "testing" image:
> http://cdimage.debian.org/cdimage/weekly-builds/arm64/iso-cd/
>
After adding console=ttyS0,115200, the kernel booted successfully. But
unfortunately the installer was not able to initialize the network
hardware. Even after trying several times

Uname + dmesg: http://pastebin.com/vMpyL86F

> Or failing that, the mini.iso from
> https://builds.96boards.org/releases/reference-platform/components/debian-installer/16.03/

After adding console=ttyS0,115200, the kernel booted successfully and
this time the installer was able to get IP address from DHCP and
download some files from Debian FTP

Uname + dmesg: http://pastebin.com/QNVxtPe6

I ran out of spare hard drives. So will try full install tomorrow using Mini ISO

> is basically a "testing" installer with some added not-yet-upstream
> patches for GRUB/kernel. If the "testing" doesn't work, I would be
> quite interested in seeing if this one helps.
>
> Regards,
>
> Leif

Thanks for your suggestions, Ronald


Reply to: