[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: nfs4 server doesn't allow ws client mount



Hi Giorgio,

On  Sa 04 Jul 2015 12:40:22 CEST, Giorgio Pioda wrote:

On Sat, Jul 04, 2015 at 10:53:12AM +0200, Wolfgang Schweer wrote:
On Fri, Jul 03, 2015 at 04:01:27PM +0200, Giorgio Pioda wrote:
[..]
> 3) Fresh WS client install via PXE/Jessie. Added with sitesummary into
>    GOsa.
> 4) Cannot login on WS, but can on tjener with all users. Also a brand
>    new jessie created user is not able to login into WS, complaining
>    that the home partition is not mounted (workstation-hosts....) but
>    the machine IS in the group

This might be caused by the 15 minute delay for changed hostnames to be
updated on the client side. As opposed to the procedure documented in
the manual, please leave the ws hostname as it is (auto-mac-xx- ...),
and maybe restart the isc-dhcp-server (just to be sure). At least this
worked for me after testing once again a pxe installed ws in a
virtualbox environment.

Wolfgang


Hi Wolfgang,

actually now I have a better (but sadly very obscure, I'm not able
to propose a fix) image of what is (not) going on.

Yesterday I were thinking that my problems arised from my special LDAP
user reload procedure. But today I worked on a fresh tjener, with no user imports
at all...

I guess there are issues with libnss-ldap or between ldap and GOsa interface, or even both.

(The short delay is for me familiar and never blocking, I just wait ldap2zone cronjob)

Regards

Girogio

I stumbled over this, as well, during the last days. I had a Debian Edu squeeze server upgraded to Debian Edu jessie, but the issue also occurred for my diskless workstation image server (while mounting the diskless machine's chroot as nfsroot) installed from scratch with a Debian Edu jessie PXE netboot installation.

The problem here was that

  innetgr -h test-host.intern workstation-hosts

does not always return with exit code 0 when nscd is running (although test-host.intern is in NIS netgroup workstation-hosts). If you switch off nscd, then my systems would all properly mount the home directories (and nfsroot chroots) via NFS.

Does this apply for your case, as well, maybe?

One reason of the issue may be that /etc/init.d/nscd does not invalidate the netgroup cache file (in /var/cache/nscd/) on service start/restart. (reported as bug against nscd package, see [1]).

Maybe we are facing the same issue? Any kind of feedback is welcome!!!

Mike

PS: I now have looked at all your recent posts and this would probably have saved my a day of debugging... Gnaaa... (I will have to follow this list more closely again in the furture!!!).

[1] https://bugs.debian.org/793649
--

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
fon: +49 (1520) 1976 148

GnuPG Key ID 0x25771B31
mail: mike.gabriel@das-netzwerkteam.de, http://das-netzwerkteam.de

freeBusy:
https://mail.das-netzwerkteam.de/freebusy/m.gabriel%40das-netzwerkteam.de.xfb

Attachment: pgpybrC5FMuxu.pgp
Description: Digitale PGP-Signatur


Reply to: