[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: nfs4 server doesn't allow ws client mount

On Sat, Jul 04, 2015 at 10:53:12AM +0200, Wolfgang Schweer wrote:
> On Fri, Jul 03, 2015 at 04:01:27PM +0200, Giorgio Pioda wrote:
> [..]
> > 3) Fresh WS client install via PXE/Jessie. Added with sitesummary into
> >    GOsa.
> > 4) Cannot login on WS, but can on tjener with all users. Also a brand
> >    new jessie created user is not able to login into WS, complaining
> >    that the home partition is not mounted (workstation-hosts....) but
> >    the machine IS in the group
> This might be caused by the 15 minute delay for changed hostnames to be 
> updated on the client side. As opposed to the procedure documented in 
> the manual, please leave the ws hostname as it is (auto-mac-xx- ...), 
> and maybe restart the isc-dhcp-server (just to be sure). At least this 
> worked for me after testing once again a pxe installed ws in a 
> virtualbox environment.
> Wolfgang

Hi Wolfgang,

actually now I have a better (but sadly very obscure, I'm not able
to propose a fix) image of what is (not) going on.

Yesterday I were thinking that my problems arised from my special LDAP
user reload procedure. But today I worked on a fresh tjener, with no user imports
at all...

I guess there are issues with libnss-ldap or between ldap and GOsa interface, or even both.

(The short delay is for me familiar and never blocking, I just wait ldap2zone cronjob)



Giorgio Pioda - Sysadmin SPSE-Tenero
Cell +41 79 629 20 63
Tel  +41 58 468 62 48
Fax  +41 58 468 61 98

Reply to: