[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Login possible only with root

Valerio Pachera skrev:
> Hi all, sorry if I reported a discussion from the admin mailing list
> but I realy need help.
> I have a debian-edu installation with the profile main, ltsp and work
> station on the same machine. It take a bit time for boot but is
> working.
> I created the account "student1" with LWAT to test a login on a thin
> client but it doesn't work: insted of load kde it goes back to the
> login screen.
> The "funny" thing is that, with root, the login works!
> I also tried to log on the local machine (kdm) with the "student1"
> user with the same resault.

Have you tried again recently with the created user "student1" ?

I guess that this is caused by missing homedirectory. The
homedirectories are created by a cronjob that by default are set to run
every 5 minutes. You could of course change that, and have it run every

The reason for this is that lwat is actually running as www-data, who
doesn't have the permissions to create a homedirectory for the user.
lwat could of course assume that the password you gave also is the
root-password, and try to create the users homedirectory. But maybe lwat
is not even running on the same machine as the fileserver,  and maybe
the fileserver is not allowing ssh-access. That is why it's set up as a

> I watched the /var/log/auth.log:
> Aug 26 03:32:08 tjener sshd[17072]: (pam_unix) authentication failure;
> logname= uid=0 euid=0 tty=ssh ruser= rhost=ltsp252.intern
> user=student1
> Aug 26 03:32:08 tjener sshd[17072]: Accepted password for student1
> from port 4692 ssh2
> Aug 26 03:32:08 tjener sshd[17074]: (pam_unix) session opened for user
> student1 by (uid=0)

This means that the user were created, and was actually allowed to log
in. The problem was that kde refused to start because it could not find
the homeDirectory (Well it's just my qualified guess).

I guess I could add some note after the user(s) are created in lwat,
telling the admin that it might take a couple of minutes before the
homedirectories are created.

> It semms to accept the the password and to open a session but...it
> realy doesn't.

Try logging in without using kde, either using kdm on the server, or the
command line, or first log in as root, then "ssh tjener -l student1"

> Any Idea ?

yes. Lets try to improve the documentation :)

Finn-Arne Johansen
faj@bzz.no http://bzz.no/
EE2A71C6403A3D191FCDC043006F1215062E6642 062E6642

Reply to: