[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: systemd effectively mandatory now due to GNOME

Brian May <brian <at> microcomaustralia.com.au> writes:

> This looks like the dependency is kernel/platform dependant:
> http://packages.debian.org/sid/gnome-settings-daemon has:
> dep: systemd [not hppa, hurd-i386, kfreebsd-amd64, kfreebsd-i386, m68k,
powerpcspe, sh4, sparc64]

That’s just because e.g. m68k hasn’t built that new package yet.
Look at the versions.

I wonder what will happen on kernels without cgroups support…
but anyway, yes, please split the package. If those services
really depend on the systemd _binary_, split between systemd
(containing only the magic needed to make it init) and another
package, say systemd-binaries, containing the rest.

If, on the other hand, those services the g-s-d needs cannot
work any more when systemd is not the init system used, then
I’d rather see gnome be removed from Debian. This is inacceptable.


Reply to: