[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: systemd effectively mandatory now due to GNOME

On Thu, Oct 24, 2013 at 04:22:50PM +1100, Brian May wrote:
> On 24 October 2013 07:30, Christoph Anton Mitterer <calestyo@scientia.net>wrote:
> > In sid, gnome-settings-daemon depends now on systemd.
> This looks like the dependency is kernel/platform dependant:
> dep: systemd [not hppa, hurd-i386, kfreebsd-amd64, kfreebsd-i386, m68k,
> powerpcspe, sh4, sparc64]
> So doesn't break Gnome where systemd is not supported.

But clearly shows this should be a Suggests: rather than a Depends:.
"Depends" is for an absolute relantionship, if five linux architectures
work fine without systemd, this means it is in no way a requirement.
Even a "Recommends" would be an abuse.


Reply to: