[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#704594: python-debian: switch ar implementation to python-arpy

Steve Langasek <vorlon@debian.org> writes:
> On Thu, Aug 01, 2013 at 04:47:45PM +0200, Helmut Grohne wrote:
>> Package: python-debian
>> Version: 0.1.21+nmu2
>> Severity: wishlist
>> Control: block -1 by 704594
>> On Thu, Aug 01, 2013 at 04:19:42PM +0200, Stefano Zacchiroli wrote:
>> > Can you please file a bug report about that (ideally marking the pending
>> > ITPs as blockers for it)? Regarding changing interfaces it would be
>> > better not to do that, of course, but even more so because it's not
>> > clear to me how many users of the debfile module are out there in the
>> > wild. We can do a call for it or something, but let's move the
>> > discussion to an appropriate bug report first.
>> Sure. Here is your bug. So let me give a summary of advantages of the
>> move:
>>  * Less code.
>>  * Works with non-seekable fileobjs.
>>  * #642020 is fixed for free (but there also is a patch).
>>  * #689313 would be obsoleted (but there also is a patch).
>>  * python-arpy has a responsive upstream and maintainer.
> The python-arpy package in the NEW queue doesn't have a python3 version, so
> this would regress python-debian.  You might want to fix this first.

  Support is there upstream. I just need to figure out how to build the
python3 variant


Reply to: