[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: ${misc:Depends} injects broken versioned depends (Was: Bug#676455: gnumed-doc: uninstallable in sid: depends on outdated libjs-jquery-livequery)

On Thu, Jun 07, 2012 at 09:28:08PM +0200, Raphael Hertzog wrote:
> The point of the symlink tree is that you can easily switch between
> using the embedded version (when the packaged version is incompatible)
> and the packaged version (through the symlink tree). If you used a
> top-level symlink, you would have to constantly add code in
> preinst/postinst to replace the symlink by a real dir and vice-versa.
> dh-linktree has been created to respond to this need and it's thus logical
> that it puts strong dependencies forcing you to re-evaluate the
> compatibility for each new upstream version of your dependency.
> I hope it's clearer now.

Yes.  It might make sense to copy this to the manual.

Thanks for the explanation



Reply to: