[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: ${misc:Depends} injects broken versioned depends (Was: Bug#676455: gnumed-doc: uninstallable in sid: depends on outdated libjs-jquery-livequery)


On Thu, 07 Jun 2012, Andreas Tille wrote:
> yesterday I uploaded the latest gnumed package including gnumed-doc
> which resulted in an uninstallable package in sid.  The broken verisons
> were injected by
>   Build-Depends: ... dh-linktree, libjs-jquery, libjs-jquery-livequery
>   Depends: ${misc:Depends}
> I suspect something is broken here with the dependency resulution.  Any
> hint?  Any more affected packages?

dh-linktree uses the version of the package on the build system to inject
a (usually strong) dependency in ${misc:Depends}. If you built the package
on a system that was not up-to-date, it's to be expected that the
generated dependency might no longer be suitable for sid.

dh-linktree generates strong dependencies on purpose because the set of
embedded files can evolve and you want to be sure that you regenerate the
binary package when the upstream version of your dependency changes.

I should probably say a word about this in the dh_linktree manual page.

Raphaël Hertzog ◈ Debian Developer

Get the Debian Administrator's Handbook:
→ http://debian-handbook.info/get/

Reply to: