[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#676479: ITP: libcatalyst-authentication-credential-http-perl -- HTTP Basic and Digest authentication for Catalyst

Package: wnpp
Severity: wishlist
Owner: Jonas Smedegaard <dr@jones.dk>

* Package name    : libcatalyst-authentication-credential-http-perl
  Version         : 1.014
  Upstream Author : Jess Robinson, Sascha Kiefer <esskar@cpan.org>,
                    Yuval Kogman <nothingmuch@woobling.org>
* URL             : http://search.cpan.org/dist/Catalyst-Authentication-Credential-HTTP/
* License         : Artistic or GPL-1+
  Programming Lang: Perl
  Description     : HTTP Basic and Digest authentication for Catalyst

 Catalyst::Authentication::Credential::HTTP lets you use HTTP
 authentication with Catalyst::Plugin::Authentication. Both basic and
 digest authentication are currently supported.
 When authentication is required, this module sets a status of 401, and
 the body of the response to 'Authorization required.'. To override this
 and set your own content, check for the "$c->res->status == 401" in
 your "end" action, and change the body accordingly.

Reply to: