[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: debootstrap loading both libept1 AND libept1.4.12, .. and fails!

Package: libept1.4.12
Severity: Important

Hi Oliver, hi Enrico, hi all,

On Di 17 Apr 2012 17:29:53 CEST olivier sallou wrote:

2012/4/17 olivier sallou <olivier.sallou@gmail.com>

I cannot get debootstrap working anymore in sid since libept update.
There is an open bug (#472704) for this but if someone has an idea of what
is going on to help the debug....

A recent upload of libept delivered binary libept1.4.12 instead of libept1
(source release 1.0.6 now).

But when debootstrap runs, it tries to get them both (libept1 from v1.0.5
and libept1.4.12 from v1.0.6).

Unpacking libept1 (from .../libept1_1.0.5_amd64.deb) ...
Unpacking libept1.4.12 (from .../libept1.4.12_1.0.6+b1_amd64.deb)

I think I understand the issue, both packages are set to Priority:
and deboostrap takes"required" and "important" by default.
Though this creates an issue to debootstrap.

same problem here. Chroot creation for my pbuilder environment is not possible anymore with a two staged debootstrap.

Both packages libept1 and libept1.4.12 get installed by debootstrap.

 $ debootstrap --foreign --arch=<myarch> \
               sid sid-<myarch> ftp://ftp.debian.org/debian
 $ cd sid-<myarch>
 $ chroot .
 $ /debootstrap/debootstrap --second-stage

libept1 depends on libapt-pkg4.10. However, libapt-pkg4.10 is not available in SID anymore, so libept1 fails to install during debootstrap.

dpkg: dependency problems prevent configuration of libept1:
 libept1 depends on libapt-pkg4.10; however:
  Package libapt-pkg4.10 is not installed.
dpkg: error processing libept1 (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:

root@japsand:/debootstrap# apt-cache show libapt-pkg4.10
N: Can't select versions from package 'libapt-pkg4.10' as it is purely virtual
N: No packages found
root@japsand:/debootstrap# apt-cache show libapt-pkg^C
root@japsand:/debootstrap# apt-get install libapt-pkg4.10
Reading package lists... Done
Building dependency tree... Done
Package libapt-pkg4.10 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'libapt-pkg4.10' has no installation candidate

Any idea how to fix this / work around this???



mike gabriel, dorfstr. 27, 24245 barmissen
fon: +49 (4302) 281418, fax: +49 (4302) 281419

GnuPG Key ID 0xB588399B
mail: mike.gabriel@das-netzwerkteam.de, http://das-netzwerkteam.de


Attachment: pgpKllfAd70ur.pgp
Description: Digitale PGP-Unterschrift

Reply to: