[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

debootstrap loading both libept1 AND libept1.4.12, .. and fails!

I cannot get debootstrap working anymore in sid since libept update.
There is an open bug (#472704) for this but if someone has an idea of what is going on to help the debug....

A recent upload of libept delivered binary libept1.4.12 instead of libept1 (source release 1.0.6 now).

But when debootstrap runs, it tries to get them both (libept1 from v1.0.5 and libept1.4.12 from v1.0.6).

Unpacking libept1 (from .../libept1_1.0.5_amd64.deb) ...
Unpacking libept1.4.12 (from .../libept1.4.12_1.0.6+b1_amd64.deb)

This creates an issue because libept1 is not compatible with libapt-pkg4.12.

I simply execute: debootstrap --arch amd64 --keyring /etc/apt/trusted.gpg --verbose  sid foooo ftp://ftp.fr.debian.org/debian

But I cannot understand why libept1 is loaded by debootstrap as I cannot find a package depending on it:

root@debiansid:/tmp# apt-rdepends -r libept1
Reading package lists... Done
Building dependency tree       
Reading state information... Done
  Reverse Depends: goplay (0.5-1)
  Reverse Depends: packagesearch (2.6+b1)

goplay and packagesearch are not in package list.



gpg key id: 4096R/326D8438  (keyring.debian.org)
Key fingerprint = 5FB4 6F83 D3B9 5204 6335  D26D 78DC 68DB 326D 8438

Reply to: