[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: dpkg predependency against tar >= 1.23, objections?

On Thu, Sep 29, 2011 at 09:28:11PM +0200, Raphael Hertzog wrote:
> On Thu, 29 Sep 2011, Steve Langasek wrote:
> > FWIW, the previous Ubuntu LTS release included tar 1.22, so using a
> > pre-dependency in Debian probably means Ubuntu will have to carry a delta
> > for this for 12.04.  A solution that works for both Debian and Ubuntu would
> > be welcome.

> Why would that be the case? It just means that tar will be upgraded
> early... but it depends only on "libc6 (>= 2.6)" which is satisfied
                                          >= 2.8

> in 12.04 so it can be upgraded without dragging anything else.

Yes, in theory this should work.  But my experience is that, even when we
can't foresee how, adding pre-depends on packages not available in the
upgraded-from release nearly always makes apt unhappy down the line.

If you prefer, you can make the change, we can merge it in Ubuntu and I'll
let you know afterwards the results of 10.04->12.04 upgrade testing :)

Steve Langasek                   Give me a lever long enough and a Free OS
Debian Developer                   to set it on, and I can move the world.
Ubuntu Developer                                    http://www.debian.org/
slangasek@ubuntu.com                                     vorlon@debian.org

Attachment: signature.asc
Description: Digital signature

Reply to: