[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: dpkg predependency against tar >= 1.23, objections?

On Thu, Sep 29, 2011 at 06:50:35PM +0200, Raphael Hertzog wrote:
> > The tar version introducing those options was 1.23, present in
> > squeeze. So it seems you are trying to upgrade a system with packages
> > still from lenny to a mix of squeeze and sid?

> > This is generally not supported, but I also agree this outcome is not
> > desirable either, I'll probably add a versioned Pre-Depends on the
> > required tar, after running it through debian-devel.

> So cc-ing debian-devel with this mail. Does anyone have an objection
> against dpkg adding this "tar (>= 1.23)" pre-dependency?

> For reference it's the fix for #640298 that added the --warning=no-timestamp
> option.

FWIW, the previous Ubuntu LTS release included tar 1.22, so using a
pre-dependency in Debian probably means Ubuntu will have to carry a delta
for this for 12.04.  A solution that works for both Debian and Ubuntu would
be welcome.

I don't see any reason that this pre-dependency would be a problem for
Debian itself given that the required version of tar is in squeeze.

Steve Langasek                   Give me a lever long enough and a Free OS
Debian Developer                   to set it on, and I can move the world.
Ubuntu Developer                                    http://www.debian.org/
slangasek@ubuntu.com                                     vorlon@debian.org

Attachment: signature.asc
Description: Digital signature

Reply to: