[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Prefix level in Quilt patches

Raphael Hertzog <hertzog@debian.org> writes:

> On Fri, 06 Mar 2009, Ben Finney wrote:
> > Yes, that could be done. It needs to be done by every user, for
> > every patch that they ever create for consumption with
> > ‘dpkg-source’. Which is why I was hoping for a way to fix it in
> > one place, for ‘dpkg-source’ specifically.
> quilt assumes -p1 by default too, using -p0 requires you to
> explicitely add -p0 in the series file. So in the end, you have to
> teach some tool at some place of the desired/actual format.

You're right. I'm now convinced that even if ‘-p0’ were supported
right now by ‘dpkg-source’, I wouldn't be any better off, and I need
to accomodate ‘-p1’ patches anyway.

Thank you for your patient explanations of the underlying issues.

 \              “Dvorak users of the world flgkd!” —Kirsten Chevalier, |
  `\                                                rec.humor.oracle.d |
_o__)                                                                  |
Ben Finney

Reply to: