[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#439389: Changes in the xine-lib package require changes in xine-frontends

Manoj Srivastava <srivasta@debian.org> writes:

>> Err, I've never heared that partial upgrades were supported. AFAIK, if
>> you decide to stay on etch and want to upgrade libxine1 only, the
>> procedure is called a 'backport'.
>         That is surprising. I have always thought that Debian supports
>  partial upgrades; which is why we are so careful with changes in dpkg,
>  and lots of people jump through hoops to allow people to install
>  packages from testing/Sid.

I stand corrected. Julien convinced my on irc that a transition plan is
needed. Fortunately it turned out to be pretty easy:

libxine1-plugins will depend on libxine1-x and libxine1-console until
lenny. after lenny is released, these two dependencies will be
dropped. For that reason my initial announcement mail still stands

Reinhard Tartler, KeyID 945348A4

Reply to: