[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#439389: Changes in the xine-lib package require changes in xine-frontends

> Le dimanche 21 octobre 2007 à 00:22 +0200, Reinhard Tartler a écrit :
>> There are two remaining packages: libxine1-x and libxine1-console. These two
>> packages are not depended on by other packages from xine-lib. Instead, the
>> frontend packages (this means a package that you maintain) is expected to
>> depend on either libxine1-x or libxine1-console, depending on if your
>> frontend is X-based or text-only/framebuffer-based.

Josselin Mouette <joss@debian.org> writes:
> If I understand correctly, we should change:
> 	Depends: ${shlibs:Depends}
> 	Recommends: libxine1-ffmpeg
> into:
> 	Depends: ${shlibs:Depends}, libxine1-x
> Is that correct?

For packages providing an X11-based frontend, yes. You might consider
keeping the Recommends: libxine1-ffmpeg.

Reinhard Tartler, KeyID 945348A4

Reply to: