[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Installation of Recommends by default on October 1st



Neil Williams <codehelp@debian.org> writes:

> The problem is that with packages like gnome-devel and gnome-core-devel
> (re: anjuta) >50% will require SOME of the Recommended packages. As a
> long term anjuta user, I would estimate that <5% of all users need ALL
> Recommended packages.

I've had exactly the same problem with one of my packages called
'libxine1'. Please compare the package relationships in Debian 'etch'
with the package relationships in Debian 'lenny'.

I splitted the off the ffmpeg output plugin in a different binary
package called 'libxine1-ffmpeg'. This makes it possible for you to
choose to not install the ffmpeg plugin at all, which wasn't possible
before. This means less crap you need to install. Usecases: buildds,
embedded systems.

> [...]
>
> Right problem. Wrong solution.

I'm curious to hear constructive suggestions from you. 

My understanding of constructive is not "Keep things as they are".

-- 
Gruesse/greetings,
Reinhard Tartler, KeyID 945348A4

Attachment: pgpfz2X3eF5TQ.pgp
Description: PGP signature


Reply to: