[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: debhelper and debconf: package and protocol versions

On Wed, Mar 21, 2007 at 02:09:06PM -0700, Steve Langasek wrote:
> On Wed, Mar 21, 2007 at 02:13:18PM +0100, Magnus Holmgren wrote:
> > dh_installdebconf adds a fixed dependency on debconf (>= 0.5) | debconf-2.0 to 
> > ${misc:Depends} if debconf is actually needed. But judging from the changelog 
> > of debconf version 1.2.0 is needed if there are any template translations, 
> > and I think dh_installdebconf should be so smart. Not that it matters now, 
> > over four years later, but it makes me wonder: Are there any other versions 
> > where new functionality was added, prompting a versioned dependency on a 
> > newer version? I've found debconf-escape from 1.4.72.
> Yes, the debconf 'error' template type was added in a version later than
> what shipped in sarge.  But then, to use this feature you can't depend on '|
> debconf-2.0' either, you have to know exactly which version of cdebconf
> implemented the same template type and depend on the 'or' of these two
> packages specifically.  So at that point, I'm not sure the behavior of
> dh_installdebconf vis à vis ${misc:Depends} is relevant.

I had an error triggered today starting from a minimal (only basic unix
machine selected in tasksel) debian etch machine upgraded to a
full-fledged unstable, by tetex-base (saying that the "description"
format was not understood). Installation of debconf-utils (which
probably pulled something else related to debconf) repaired the thing
(tetex-base could not be removed nor configured, due to the debconf
error). This error may come from the fact that I preseeded the debconf
tree (and I use a non-default debconf configuration).

Reply to: