[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

debhelper and debconf: package and protocol versions



dh_installdebconf adds a fixed dependency on debconf (>= 0.5) | debconf-2.0 to 
${misc:Depends} if debconf is actually needed. But judging from the changelog 
of debconf version 1.2.0 is needed if there are any template translations, 
and I think dh_installdebconf should be so smart. Not that it matters now, 
over four years later, but it makes me wonder: Are there any other versions 
where new functionality was added, prompting a versioned dependency on a 
newer version? I've found debconf-escape from 1.4.72.

Further, will transitioning to cdebconf be possible if the only common 
specification is that behind the debconf-2.0 virtual package 
(http://www.debian.org/doc/packaging-manuals/debconf_specification.html)? 
Should everything that isn't on the other end of the communication channel 
from the point of view of the maintainer scripts be separate packages, 
including debconf-escape as well as /usr/share/confmodule? All packages that 
depend on debconf should simply add debconf-2.0 as an alternative, but AFAICS 
almost no packages can possibly work without debconf, because they need 
confmodule at the very least.

Can somebody clarify?

(I've seen http://bugs.debian.org/395166 (dh_installdebconf: Should try to 
figure out the debconf version needed).)

-- 
Magnus Holmgren        holmgren@lysator.liu.se

Attachment: pgpexnYypgXxc.pgp
Description: PGP signature


Reply to: