[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Why does Ubuntu have all the ideas?

Am Sonntag 27 August 2006 07:05 schrieb Theodore Tso:
> On Sat, Aug 26, 2006 at 04:02:04PM +0200, Hendrik Sattler wrote:
> > - installer did not read in the CDs for package lists and the GUI does
> > not even support this (or for any other means of modifying
> > /etc/apt/sources.list)
> >
> >From the menubar.  System --> Administration --> Synaptic Package Manager

Funny, Synaptic was not installed but something called adept. Guess what you 
have to do to install Synaptic ;)

> > - /etc/resolv.conf was not present but DHCP client complained about that
> Hmm, I didn't notice this problem.  When the dhcp client started
> during the install process, it created the /etc/resolv.conf file for
> me, and subsequent dhcp clients updated the /etc/resolv.conf file
> information automatically from the DHCP serve.

As I said, only a "touch /etc/resolv.conf" solved the problem.

> > - the "root has no password and you must use sudo" sucks for many things
> > as the access to root is not consistent (some invocation type can use su
> > programs but those cannot work).
> That's a philosophical dispute, but it's easily fixed simply by
> setting a root password if you really want to use a root shell.  (Or
> by just doing sudo bash, of course.)  I happen to like having a root
> user with a password and to su to root, so I set up my system that
> way.  However, I view that as an emacs vs. vi sort of religious
> dispute.

I meant the graphical su variants, IIRC it's called gtksu. Sure, those things 
are solvable if you know why they do not work and what's actually the 
difference between *su and sudo. However, the one that installed this machine 
did not know this (now he does).

> > - X ran with the wrong resolution (typical i915 problem) and with the
> > wrong dpi setting
> Can't speak to that; my ATI Firegl video worked automatically out of
> the box --- with 3D accelerated graphics automatically.

Xorg seems to be broken here, too, as i915resolution showed me entries where 
xorg said they were empty. Strange.

> > - /etc/network/interfaces listed non-existant devices and because of WPA,
> > a manual setup of this file is needed
> I didn't notice that problem.

Well, I guess installing wpa_supplicant _and_ network-manager would have 
solved that problem.

> > - something useful like ifplugd was not installed and the user was
> > puzzled by the fact that plugging in the network cable did not
> > result in network access
> I agree that it would be nice if ifplugd or laptop-net were installed
> by default, but last I checked Debian didn't install either by
> default, either.  So what's your point?

It's all about expectations. Always keep in mind that the target group differs 
a lot between Ubuntu and Debian.


Reply to: