[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: cross-compiling Debian packages

Nikita V. Youshchenko wrote:

You have too old version of libgcc1-arm-cross, that does not provide
libgcc1-arm-dcv1 (and, btw, installs to /usr/arm-linux/)
 No, that's not true. It does install into /usr/arm-linux-gnu.
I got this one from the latest gcc sources
(4.0.2-9). And it still does not provide libgcc1-arm-dcv1. I always
compile stuff from sources BTW, so that should have produced correct
cross package...

Aiieee...I see. How this could stay unnoticed until today?..
Probably nobody uses this stuff :(

Hopefully not, at least I am planning to use this on a larger scale;-)

Quick workaround: use dpkg-cross on libgcc1 arm binary package from debian archive.
Proper fix will follow as soon as soon as I find time for that.
I hope that my patches (#357629, <mailto:357629@bugs.debian.org> #357658 <mailto:357658@bugs.debian.org>, #357661 <mailto:357661@bugs.debian.org>) are proper enough:-)

Reply to: