[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: sarge uninstallable !?!

* A. Mennucc:

> in both cases, the first part of the install was OK, but, after
> reboot, when APT was called to upgrade the system, it stopped
> claiming:
>  E: This installation run will require temporarily removing the essential 
>  package e2fsprogs due to a Conflicts/Pre-Depends loop. This is often bad, 
>  but if you really want to do it, activate the APT::Force-LoopBreak option.

I've seen this as well, but attributed it to an old sarge installer
which used "testing" instead of "sarge" (or "stable") in the installed
sources.list file.  In this case, an update from a pre-sarge testing
snapshot (is installed by the base system) to a current etch version
is attempted.  Such cross-release updates are not supported.

By the way, your Mail-Followup-To: header is broken.

Reply to: