[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

sarge uninstallable !?!

hi everybody

two friends of mine tried (separately) to install sarge using the
netinst cdrom, and failed 

in both cases, the first part of the install was OK, but, after
reboot, when APT was called to upgrade the system, it stopped
 E: This installation run will require temporarily removing the essential 
 package e2fsprogs due to a Conflicts/Pre-Depends loop. This is often bad, 
 but if you really want to do it, activate the APT::Force-LoopBreak option.

this seems the same problem as in bugs 330719 and 325834 ....  but
this is incomprehensible to me! the above bugs should never affect
people doing a new install of sarge on a formatted disk!

These 2 friends phoned me (one yesterday, one today) asking for
help; here is what I can report to you (informations are scarce,
getting technical details on the phone is not easy):

1st friend used an italian mirror (one of the 'garr' , I dont know if
it was 'cdn.mirror.garr.it' ); after APT stopped, he was left with an
unworkable system, that would not even reboot properly; wed. he
phoned me, and tried again while I was consueling thru the phone; we
used 'ftp.it.debian.org' as mirror, and installation was flawless

2nd friend used 'debian.fastweb.it' ; he googled around, found many
pages reporting this kind of problem, so he reissued APT with 'apt-get -o
APT::Force-LoopBreak=yes' and managed to complete the install.

I can imagine only two possible explanations:
 - broken mirrors where stable points to etch
  (but I checked this, and the above mirrors seem OK)

 - some new package that comes from 
    deb http://security.debian.org stable/updates main
  is triggering the above prbl with e2fsprogs


Andrea Mennucc
 "E' un mondo difficile. Che vita intensa!" (Tonino Carotone)

Attachment: apt.tgz
Description: GNU Unix tar archive

Attachment: signature.asc
Description: Digital signature

Reply to: