[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: curl situation is intolerable

Paul TBBle Hampson <Paul.Hampson@anu.edu.au> writes:

> Mind you, the license/OpenSSLCallback conflict neccessarily
> segregates the packages into two camps, those which are GPL, and
> those which need the callback only supplied by the OpenSSL-linked
> libcurl.

You misunderstand my complaint.

I do not care that a given package cannot link to SSL and also be
GPLd.  That's a hassle, but it's endurable.

What I complain is that, once the packages have been so segregated, it
is now *impossible* to even install both kinds on the same Debian
system at the same time.  *That* is intolerable.

I don't care about the callback.  The package maintainers have the job
of deciding whether the packages implement the same ABI or not.

If the answer is "yes", then they should both be drop-in replacements,
and Provide the same virtual package.

If the answer is "no", then they should install different files in the
Debian namespace and should not Conflict with each other.

DECIDE, and then do whichever.  But the current "solution" is utterly


Reply to: