[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Who needs libcurl3?

* Goswin von Brederlow (brederlo@informatik.uni-tuebingen.de) wrote:
> I guess the savest way is to have a libldap-nossl-dev and
> libldap-ssl-dev. The former should have anything ssl derived
> removed.

No, that was *worse*.  We tried that before.  The answer really is
reasonably simple- just modify libldap2 to use GNUTLS.  That was done w/
an older version of things involved.  I expect it'll be done for the
newer stuff.

> Packages without linking exception can then Build-Depend on
> libldap-nossl-dev. If the ssl and nonssl ldap has the same ABI (nonssl
> being a subset of ssl to be precise) the package can work with either
> lib then.

Bleh.  Let's just move off of OpenSSL where we can.  This is a case
where we can, and people have worked on it already, let's finish that
off and this time get upstream to accept it (they're annoyingly anal
about such things) and be done with it.


Attachment: signature.asc
Description: Digital signature

Reply to: