[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: RFS: libssh - SSH and SCP library


> > > Should the package name contain the version number? (like the libssl
> > > packages)
> > 
> > Yes, it should be called libssh-0.11-0.
> I'd rather call it libssh0.11 or libssh-0.11, since the -0 is the
> package version number (I took the libssl0.9.7 package as example :
> package name is libssl0.9.7, package version is 0.9.7g-1, and package
> filename is libssl0.9.7_0.9.7g-1_i386.deb).

You are looking at the wrong part of the wrong package, 
because libssl is one of the few exceptional packages which 
really do have that soname,

$ objdump -p /usr/lib/libssl.so.0.9.7 | grep SONAME
  SONAME      libssl.so.0.9.7

Call your package libssh-0.11-0.

Quoting from the libpkg-guide (which itself is a quote from vorlon)
I pointed out to you and you probably have not read yet:

	$ objdump -p /path/to/libfoo-bar.so.1.2.3 | sed -n -e's/^[[:space:]]*SONAME[[:space:]]*//p' | sed -e's/\([0-9]\)\.so\./\1-/; s/\.so\.//'


Junichi Uekawa, Debian Developer   http://www.netfort.gr.jp/~dancer/
183A 70FC 4732 1B87 57A5  CE82 D837 7D4E E81E 55C1 

Reply to: