[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Upload new version of gaim-extendedprefs

On Tue, Jun 28, 2005 at 12:34:01PM +0200, Arjan Oosting wrote:

> > > If it really should not be done, maybe a check could be added to lintian
> > > and/or linda and CDBS and the policy should be updated.
> > 
> > There *is* a lintian check for this, and there is no need for policy to be
> > updated -- just for you to follow it.
> Well my package *is* lintian and linda clean, so I guess the check is
> broken or I am doing something awefully wrong ;) I will attach the debug
> output of lintian.

$ echo 'E: foo source: depends-on-build-essential-package-without-using-version' | lintian-info 
E: foo source: depends-on-build-essential-package-without-using-version
N:   The package declares a depends on a build essential package without
N:   using a versioned depends. In general a package should not depend on
N:   build essential packages but if it must do so, the depends should have
N:   a version string.
N:   Refer to Policy Manual, section 4.2 for details.

Yeah, so I don't know why this check isn't being triggered if it applies to
your package.  The version of gaim-extendedprefs in the archive doesn't seem
to have any build-deps on build-essential packages, so I can't compare.

Steve Langasek
postmodern programmer

Attachment: signature.asc
Description: Digital signature

Reply to: