[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Serious kernel problems on new i386 hardware

On Thursday, 10 de March de 2005 15:10, Andreas Tille wrote:
> I tried to upgrade to a 2.6.x kernel but failed always with kernel_panic.
> I tried 2.6.8, 2.6.8 and 2.6.10 (here -1-386 and -1-686 versions) and
> all failed with the same result:
>    ERROR: Removing 'trm290': Device or resource busy
>    ERROR: Removing 'vis82cxxx': Device or resource busy
>    pivot_root: No such file or directory
>    /sbin/init: 432: cannot open dev/console: No such file
>    Kernel panic - not syncing: Attempt to kill init!

I've recently had those problems also on a Dell server, using SATA too. The 
fine guys from #gpul helped me a lot on this. Basically, what happened to me 
is that kernel 2.4 mapped the SATA drive as /dev/hdc and kernel 2.6 mapped it 
to /dev/sda
So I booted using the installer with the linux26 option, followed the 
installation until the HD partitioning screen, jotted down the hard disk 
device (/dev/sda), switched to console 2 and mounted the partition. Then I 
changed /etc/fstab and /boot/grub/menu.lst acordingly. Everything worked fine 
when I rebooted.

That's what I did on the same symptoms and worked for me. 

 temp: http://temp.roncero.org
 Out: 17.69 ºC --  In: 19.38 ºC

Reply to: