[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Serious kernel problems on new i386 hardware

On Thu, Mar 10, 2005 at 03:10:12PM +0100, Andreas Tille wrote:
> Hi,

> I've got a new Dell machine which I was able to install with Kernel 2.4.27.
> It has a SATA drive but I disabled SATA in BIOS according to the manuals.
> All I write in the following has this SATA disabled BIOS setting.

> As I said kernel 2.4.27 works fine.  I attach a dmesg and syslog to this
> mail.

> I tried to upgrade to a 2.6.x kernel but failed always with kernel_panic.
> I tried 2.6.8, 2.6.8 and 2.6.10 (here -1-386 and -1-686 versions) and
> all failed with the same result:

>   pivot_root: No such file or directory
>   /sbin/init: 432: cannot open dev/console: No such file
>   Kernel panic - not syncing: Attempt to kill init!

> ata: 0x1f0 IDE port busy
> ata1: SATA max UDMA/133 cmd 0x170 ctl 0x376 bmdma 0xFFA8 irq 15
> ata1: dev 0 ATAPI, max UDMA/33
> ata1: dev 1 ATAPI, max UDMA/33
> ata1: dev 0 configured for UDMA/33
> ata1: dev 1 configured for UDMA/33
> scsi0 : ata_piix
> elevator: using anticipatory as default io scheduler
> Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
> ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
> ide0: I/O resource 0x1F0-0x1F7 not free.
> ide0: ports already in use, skipping probe
> ide1: I/O resource 0x170-0x177 not free.
> ide1: ports already in use, skipping probe

This is your problem here. You made your initrd under 2.4.27, where your
devices where /dev/hd?. However, 2.6 with the initrd has loaded them
with the SATA driver, and sees them via /dev/sd?.

I think you're going to have to manuall edit your initrd and fstab to
deal with the change in device name between versions.

Alternatively, pull ata_piix driver out of the initrd, and see if the
ide driver will load and run your disks.

However, that first line (IDE port busy) worries me a little, since it
seems neither driver is actually claiming the port itself.

If you want to experiment, there's a command you can put on the Linux
kernel command line to break into the initrd before it actually does
anything, and you can see what devices exist and drivers and whatnot.

I can't remember the command though. -_-

Paul "TBBle" Hampson, MCSE
8th year CompSci/Asian Studies student, ANU
The Boss, Bubblesworth Pty Ltd (ABN: 51 095 284 361)

"No survivors? Then where do the stories come from I wonder?"
-- Capt. Jack Sparrow, "Pirates of the Caribbean"

This email is licensed to the recipient for non-commercial
use, duplication and distribution.

Attachment: signature.asc
Description: Digital signature

Reply to: