[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#159606: marked as done (general: Gnome packaging crash prone, Xsession.)

Your message dated Thu, 29 Jul 2004 02:38:57 +1000
with message-id <20040728163857.GQ23526@fooishbar.org>
and subject line Irrelevant, random bug report
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

Received: (at submit) by bugs.debian.org; 4 Sep 2002 14:16:55 +0000
>From jdh@hend.net Wed Sep 04 09:16:55 2002
Return-path: <jdh@hend.net>
Received: from ip68-100-131-54.nv.nv.cox.net (link.hunter) [] 
	by master.debian.org with esmtp (Exim 3.12 1 (Debian))
	id 17maxj-0005d5-00; Wed, 04 Sep 2002 09:16:55 -0500
Received: (from jdh@localhost)
	by link.hunter (8.11.3/8.11.3) id g84AH6W05209;
	Wed, 4 Sep 2002 06:17:06 -0400
Message-Id: <200209041017.g84AH6W05209@link.hunter>
From: "John D. Hendrickson" <jdh@hend.net>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: general: Gnome packaging crash prone, Xsession.
X-Mailer: reportbug 1.50
Date: Wed, 04 Sep 2002 06:17:05 -0400
X-BadReturnPath: jdh@link.hunter rewritten as jdh@hend.net
  using "From" header
Delivered-To: submit@bugs.debian.org

Package: general
Version: N/A; reported 2002-09-04
Severity: important

-- System Information
Debian Release: 3.0
Architecture: i386
Kernel: Linux link 2.2.20 #1 Sat Apr 20 11:45:28 EST 2002 i586


I've found a few problems with the X startups: which often don't really
start X :)

I think many user problems would go away if permissions were checked when
gnome installs (or perms were tested in cron run).  Since permission
checks are somewhat standard in other packages, this should be possible.

I find gnome is far to suceptible to not working.  You log in with gdm
and then get kicked out - back to gdm.  You finally get in (likely
by giving up your old desktop), you have no login environment.  You
uninstall and reinstall - but required files are still missing.  Load
gmc: sometimes it closes and opens in a loop.

When Gnome doesn't load it often leaves no log messages or console
messages as to why: you'd have to get the source or just guess.

I put an old script of mine below about the HOME directory and Gnome.

GDM BUG:  GDM does not really login users correctly:

	--> GDM logs in the user without a login ENVIRONMENT <--

	--> XDM logs in the user WITH a POSIX login ENVIRONMENT <-- 
	(xdm can launch gnome easily)   

	After much work figuring out why my login ENV wasn't being
	loaded, I narrowed it down to GDM (because everything GNOME
	works until GDM enters the picture).  I wrote the author
	and of course got no reply.

	(You might not notice this unless you use a POSIX compliant
	login environment that sets environment variable when.  A
	workaround for bash is below.)

DEBIAN BUG:  Xsession

	Xsession breaks the Xfree86 starup rules - with the meantion that
	those 'old startups' didn't handle multiple startups.  That is
	is just plain wrong.

	However, Xsession ISN'T IN THE LOOP for Gnome startup.

	So, if its not 'IN THE LOOP' for starting the big few desktops, why 
	does it need to ignore Xfree86 configs which work with xinit, xdm, 
	startx (had Xsession not been there to misconfigure things ??)

	That is: why does Xsession need to rename the startup files and
	call them in a different order -- but add nothing new to the
	startup process ??  
	Certainly, a 'run-parts' could be in the system 'xinit'.  So
	that is not an answer.  Xinit, startx, xdm, ... have allways
	been compatible with multiple window managers.  That's nothing
	new in any system.

	However, Xsession breaks the POSIX starup rule that allows the
	user to control their own starup in their home directory(s).

	Of course the old configs *were* carefully organized to allow
	system defaults AND user control as well - because it is the
	unix way to allow the user to run non-root software they have
	permission to run - they way they need to run it, right?


	John D. Hendrickson



# --------------------------------------------------------------

# Below: some talk and a script pertaining to Gnome files in $HOME,
# and some solutions to various broken things.
# NOT GAURANTEED, of course
# Q: Some users can log into Gnome - some can't.
# Q: I login with "gdm" - but it brings me back to the login.
# Gnome may not load or do WEIRD things if its file and directories are 
# setup wrong.  For example - after "gdm" loging you don't get a spash 
# and it exits.  Or no splash and just a plain destop.  Also, you might 
# find "gmc" is acting weird - like it will open and close immediately 
# in a loop and applications aren't launching.
# The below script can fix some simple problems.
# Try this from the prompt to see if it will work.
# (insure X is shutdown first, of course)
# 	bash# X vt7 & xterm &   # This should work.  Ctrl-Alt-Backspace.
# If it does not - then you may have a STARTUP problem - not a Gnome
# configuration problem.  Startup problems is a very big topic which
# can span X, /etc/profile, /etc/X11, pam, gdm.conf, ssh, Xsession, 
# and worse.  Try reinstalling :)  As your linux distribution gets 
# bigger - so trouble shooting problems.
# also try:
# 	bash# X vt7 & gnome-session &
# If that doesn't work but the first did - then you likely have a gnome
# configureation problem.  However - if the second line worked - but
# your "gdm" logins don't.  Hmm... Could be gdm - many something else.
# --->
# So don't bother with this script 1 and 2 worked as the same user in
# question.
# --->
# Gnome's greatest design flaw ist thoughtless startup complexity, poor
# error reporting, and no fail-safe, all combined.  Why doesn't it just
# start a basic desktop and THEN go goofing around ?? :)
# Corrupt or misconfigured things like those little startbar apps,
# and incorrect launchers can cause severe enough problems to prevent 
# you from getting in.  SSH will cause problems too.  Can't fix that
# here.  The answer to those things are: start with a fresh user account and
# let gnome re-create the default structure.  Step by step, get back
# what you can.
# Personally, that is why I like Motif - its seldom "surprising", seldom
# not functional.  KDE?  Nice.  But its not all open source and it crashes too
# much.  But definitely nice.
# My not gaurunteed advice is this.  [Backing up your files first.]
# If some users can log in and other's can, its likely the startup files
# Gnome undocumentedly requires when loading.
if [ "`id -u`" = "0" ] ; then
	# if root user
	if [ -z $1 ] || [ -z $2 ] ; then
		echo "Root must provide args: user homedir" >> /dev/stderr
		echo "Where homedir is fullpath of all users." >> /dev/stderr
	if [ ! -d "$HOME/$USER" ] ; then
		echo "Users directory unknown." >> /dev/stderr
		echo "Please adjust script." >> /dev/stderr
echo "--> $HOME/$USER" >> /dev/stderr
ALL=".gnome .gnome-desktop .gnome_private Desktop"
ALL="$ALL "".sawfish .sawmill .mc"
for x in $ALL
	for y in $(find $x -type d) ; do chmod +xr $y ; done
	chown -R $USER:$USER $x
	chmod -R +r $x
# if you don't fix Trash, gmc will open and close continually... neat...
chmod 0700 .gnome/metadata.db .gnome-desktop/Trash.gmc
# X's authority mechanism do report errors correctly.  But here we go.
chown $USER:$USER .Xauthority .ICEauthority
chmod 0600 .Xauthority .ICEauthority
mkdir gnome-old
rm .gnome/.gnome-smproxy*
# you might remove .gnome/metadata.db - if it is corrupt
rm -r /tmp/orbit-$USER
rm -r /tmp/sawfish-$USER
# NOTE: Destop is *has*to*be a link.  But just incase it isn't...
mv Desktop gnome-old
ln -s $HOME/$USER/.gnome-desktop Desktop
# try uncommenting the below if the above didn't work
function func () { 
	mkdir gnome-old
	mv .gnome gnome-old
	mv .gnome-desktop gnome-old
	mv .gnome-private gnome-old
	mv Desktop gnome-old
	#rm -r .gconf*

# func # uncomment if the permissions didn't work

# Now login with gdm as usual
# Note $USER may not have the authority to change permissions on some
# of the files.  The answer is to run that script as root.

# Delete the chmod binary and never use it again :^)

# This needs to be somewhere in your startup BEFORE X is executed.  
# Use this if you find that when you click on things in the start panel 
# they never open.

# A 'pet peive' of mine is that when you "log in" you are not actually
# logged in by POSIX standars.  That is: when you login from GDM you
# get an "interactive NON LOGIN" ENVIRONMENT.  The "environment" is the
# restrictions under which all programs run -- so environment is
# certainly critical as to unix.

# An indication this is happening is that you see: 'bash$ ' as a prompt
# instead of your 'user@hostname:/' prompt.  Though ultimately the
# problem is worse.

# SO... to get "logged in" under a default Gnome distribution you must
# a) (fix the problem?) or b) specifically invoke bash with --login from an
# xterm 

# Soo... HowDoI fixit?  There are two ways - neither are POSIX.
# They aren't solutions: they are hacks for broken systems.
#	1) set BOTH ENV and BASH_ENV (see bash's manpage).
#	2) ln -s $HOME/.profile $HOME/.bashrc
#	3) if your using sh - forget it - your stuck with --login

Received: (at 159606-done) by bugs.debian.org; 28 Jul 2004 16:38:57 +0000
>From daniel@fooishbar.org Wed Jul 28 09:38:57 2004
Return-path: <daniel@fooishbar.org>
Received: from fooishbar.org (tycho.fooishbar.org) [] (postfix)
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1BprSD-0000ap-00; Wed, 28 Jul 2004 09:38:57 -0700
Received: by tycho.fooishbar.org (Postfix, from userid 1000)
	id 43DE6E9C47D; Wed, 28 Jul 2004 09:38:57 -0700 (PDT)
Date: Thu, 29 Jul 2004 02:38:57 +1000
From: Daniel Stone <daniels@debian.org>
To: 159606-done@bugs.debian.org
Subject: Irrelevant, random bug report
Message-ID: <20040728163857.GQ23526@fooishbar.org>
Mime-Version: 1.0
Content-Type: multipart/signed; micalg=pgp-sha1;
	protocol="application/pgp-signature"; boundary="WuT04sMzYDXq8et0"
Content-Disposition: inline
User-Agent: Mutt/1.5.6+20040523i
Delivered-To: 159606-done@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2004_03_25 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-3.0 required=4.0 tests=BAYES_00 autolearn=no 

Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

This bug report is irrelevant, incoherent, random, disconnected,
christing puce!

Closing this bug report which is more of a three-stage rant, with a
shell script the display manager has no place running, as invalid.

Daniel Stone                                                <daniels@debian=
Debian: the universal operating system                     http://www.debia=

Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: Digital signature
Content-Disposition: inline

Version: GnuPG v1.2.4 (GNU/Linux)



Reply to: