[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Jabberd2 packaging question

I'm running into a minor hitch with the Jabberd2 packaging and looking
for advice on the preferred way to handle the problem.

The previous package of jabberd2-bdb (2.0s2-1) required libdb4.1.  The
upcoming package will use libdb4.2.  Between these two versions the log
file format has changed (db format has remained the same).  This change
appears to require that the db4.1_recovery utility from db4.1-util be
run against the existing database prior to starting the new version of
jabberd2-bdb which uses the newever libdb4.2.

My problem is that adding a Depends: entry for db4.1-util seems wrong to
me since it's not truly required.  It's only needed when upgrading from
the pervious version of the jabberd2-bdb package.

Any advice on how to handle this?  Am I completely off my rocker and
missing a simpler way of handling this transition?

Jamin W. Collins

Facts do not cease to exist because they are ignored. --Aldous Huxley,
"Proper Studies", 1927

Reply to: