[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Proposed change to debian release system

On Mon, Dec 22, 2003 at 02:22:42PM +1100, Hamish Moffatt wrote:
> On Sat, Dec 20, 2003 at 05:56:51PM +0100, Adrian Bunk wrote:
> > SpamAssassin in unstable depends on a version of libhtml-parser-perl 
> > more recent than the one in unstable.
> 2.60-1 (with incorrect dependencies according to #214019, fixed in
> 2.60-2) installs and works fine on woody. 
> SA only depends on perl >= 5.6, so perhaps the deps could be changed to
> only require the newer libhtml-parser-perl if perl 5.8 is being used.

OK, you have shown that it would be possible in this specific case.

But perhaps the next version of SpamAssassin will _require_ Perl 5.8 

Besides this, you can install the 2.60-1 spamassassin deb on stable, but 
you can't fulfill the build dependencies (debhelper), which would become 
a nightmare if there would e.g. be a security update required.

> Hamish


[1] This is meant as an example. It might be untrue for SpamAssassin, 
    but I hope you get the point.


       "Is there not promise of rain?" Ling Tan asked suddenly out
        of the darkness. There had been need of rain for many days.
       "Only a promise," Lao Er said.
                                       Pearl S. Buck - Dragon Seed

Reply to: