[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: emacs mode for running debuild, debc, and debi etc.

On Fri, Oct 18, 2002 at 03:58:32PM +0200, Roland Mas wrote:
> > What about this devscripts-el stuff?  If it's small enough that it
> > doesn't need byte-compiling, what are the options in that case?  (It
> > still wants to be in the default load-path and to be noticed by the
> > emacsen so that M-x devscripts-mode or whatever works.)
>   Since it's Elisp only, it makes no sense to install it if you don't
> have any Emacs variant installed.  The devscripts-el package (soon to
> be uploaded, promise) therefore depends on emacs21 | emacsen.  It also
> depends on emacsen-common, because it requires a recent enough version
> of it.

No, what I'm thinking is if it's only a tiny script which doesn't
really need byte-compiling, and it's easy to install in such a way
that we don't have to depend on emacs*, and yet emacs will find it if
emacs is installed at any point, then it might as well go in the
devscripts package itself, rather than having yet-another-little-package.



      Julian Gilbey, website: http://www.maths.qmul.ac.uk/~jdg/
   Debian GNU/Linux Developer, see: http://people.debian.org/~jdg/
     Visit http://www.thehungersite.com/ to help feed the hungry

Reply to: