[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: why perl 5.8 won't be in testing for a while

Joey Hess (joeyh@debian.org) wrote:
> Ardo van Rangelrooij wrote:
> > Joey Hess (joeyh@debian.org) wrote:
> > [snip]
> > > libxml-parser-perl	FTBFS on ia64 due to unmet build dep. Retry.
> > 
> > Well, actually 'libxml-parser-perl' depends on 'libwww-perl' which
> > depends on 'ibmime-base64-perl (>= 2.1)'.
> It used to have a broken dependnecy, that is long past cleared up,
> that's why I said "retry".

Ok.  I see.

Another thing we need to keep in mind is that various Perl modules are not
ready yet for 5.8.  On the perm-xml mailing list there was even the question
raised as to why some (or all) of the major Linux distros already moved to
5.8 given the fact that it might take several months before all the Perl
module are 5.8-ready.  Especially UTF8 related things are bound to break.

I for one have several modules which build ok, but fail during testing.  So
I have changed temporarily the rules to '-$(MAKE) test', especially since
the number of failing test cases is rather small.

Ardo van Rangelrooij
home email: ardo@debian.org
home page:  http://people.debian.org/~ardo
GnuPG fp:   3B 1F 21 72 00 5C 3A 73  7F 72 DF D9 90 78 47 F9

Reply to: